Bitreactive

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Compile error in selfie with MQTT tutorial

Sukanto Jun 29, 2015 03:32PM CEST

Hello,
I tried to do one of your tutorials, " How to use MQTT by adding one block to your application"

When I try to build I get a compilation error with
"import com.gaborcselle.persistent.PersistentQueue;"

How do I get further

Regards Sukanto

1 Community Answers

Best Answer
Linda Ariani Gunawan Jun 29, 2015 04:23PM CEST

Hi,

Thank you for your question.

It seems our buffering library uses persistent queue Java API that is not linked with the corresponding block.
To fix the problem, you can choose one of the following two solutions.

Solution 1: Update the Buffering library

We have updated the buffering library to include PersistentQueue API. So, you can update yours and rebuild your application.

  1. Here is how to update libraries
  2. To rebuild, choose Build → Re-Build … from the context menu of your application block

Solution 2: Updating classpath

You can also update the classpath to include the missing Java class.

  1. Download the API
  2. Update your project’s classpath as described here

Feel free to contact us for further assistance. :-)

Best regards,
Linda Ariani Gunawan
Bitreactive AS


This question has received the maximum number of answers.

support@bitreactive.com
http://assets0.desk.com/
false
bitreactive
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete