Bitreactive

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Hello World

Valentino Sep 11, 2014 12:28AM CEST

Hey , tried first tutorial.

Steps.. drop down menu.. there is no,

1. 5x5


2. Add an activity "final node" ??

--- There is only "Final Flow" so i added that.

3. Add Operation .. 5x5

Next:

Right-click to reveal the menu, and select Control Flow

4 First I found Flow Final, thats not it.

Searched again..

Found, "Add Edge" in drop down. So i used these arrows..

Compiled and ran.. Spit this..

at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at sun.launcher.LuncherHelper.checkAndLoadMain(LauncherHelper.java:482)
Caused by: java.lang.ClassNotFoundException: javax.jms.MessageListener
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
... 13 more

Up 1 rated Down
Kathrin Winkler Sep 17, 2014 10:56AM CEST Bitreactive Agent

Hi,

when creating the Hello World Behavior in Step 4, you need to add an “activity final node”, which you will find by right-clicking the block → Add… → Activity Final.
(All activity nodes are described here: http://reference.bitreactive.com/reference/activity-nodes.html)

An edge can be either a control flow or a object flow. So add an edge by right-clicking the block → Add… → Edge.
You will find more about activity edges here: http://reference.bitreactive.com/reference/editing-data-flows.html

Have you created the same behavior as shown in the screenshot of the tutorial (within Step 4)?

The output when running Hello World looks rather rare. There is no javax.jms…. involved in the Hello World system. Have you chosen “Java Standard Edition” in the platform dialog when building the application? Did the …helloworld_exe project in the Package Explorer look ok (no red errors)? Have you chosen “Run As/Java Application” when running the …_exe project? Have you chosen the right java application (something like Start – my.project.helloworld) when asked to Select Java Application?

I guess we need some more input from you to figure out what has happened :)
Kathrin Winkler

This question has received the maximum number of answers.

support@bitreactive.com
http://assets3.desk.com/
false
bitreactive
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete